Skip to content

Minimum Computer Requirements

Supported Browsers

Browsers for PC

·         AOL:  Not Supported

·         Internet Explorer:  8.0, 9.0, 10.0

·         Java:  7.2 or Latest Version

·         Mozilla Firefox:  19.0, 20.0 

·         Netscape:  Not Supported

·         Safari:  Not Supported

Browsers for Mac

·         AOL:  Not Supported

·         Internet Explorer:  Not Supported

·         Java:  10.0 or Latest Version

·         Mozilla Firefox:  16.0, 17.0, or Latest Version

·         Netscape:  Not Supported

·         Safari:  4.0, 5.0, 6.0

Java must also be downloaded to the student’s computer. This download is available at www.java.com free of charge.

Please click here for the most up-to-date requirements.